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Introduction of KiCad and the usage

M2 Masaya Ono



Abstract

« Studied how to use CAD to design boards for my experiment
« Summarized what | learn

« Share and introduce the usage of CAD tool “KiCad”

€lCad



Motivation

| need RFQPD for my experiment and
designing the circuit board

The latest version of KiCad 6.0.2 (2022/05)
but information about KiCad on the
internet are mainly for Version 5

Version 6 Interface is a little different from
that of Version b
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What is KiCad ?

Features
« Completely free

« We can simulate the behaver of circuits like spice in KiCad
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Installation of KICAD and Launch a project

You can download KiCad from https://www.kicad.org/

This page (Japanese) is useful to install Kicad

- Downloading
- |Installing
- Changing language settings to Japanese

First, we make a new project

Project name example: LowPassFilter

2 files are created automatically

*#* kicad_sch file is for a circuit diagram
*** kicad_pcb file if for a circuit board

Fo¥zgh Iroll

2 Q@ e wm:s

- E LowPassFilter.kicad_pro

§

LowPassFilter-backups
LowPassFilter.kicad_pcb

LowPassFilter.kicad_sch
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KiCad EDA

A Cross Platform and Open Source Electronics Design

Automation Suite

B Documentation X Download & & & E See what's new
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https://www.kicad.org/
https://marunaka-blog.com/kicad-download-install/1426/

Flowchart of Designing and manufacturing circuits

Drawing circuit diagram

Arrange components(symbols)
Wiring

] ] Ulspice’
- Simulation LT
Models may be needed installing

- « Set some parameters

D

[€ICad

= AUTODESK
= EAGLE

Designing circuit board
Arrange components(footprints)
Wiring
Check the designing rule

CADLUS. ¢

Pﬁ E—=/NYRybhdLAh

Place an order

Prepare for gerber data
Estimate
Place an order




Drawing circuit diagrams




Arranging symbols

- EBEIF {9
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Symbols: figures displaying components
Click :[;;')— , and open window to choose symbols

Can put symbols by clicking as you like

is used

.-
B

in

!

mil

P A

415\@5 ﬁg \[ﬁ ‘3

K15494 Y 62,23

SUTNEZR (1M70BOTA FLAO-FERTLET)

Q phs-
TATL L]
v - BiEEREh: -
R Resistor
C Unpolarized capacitor
3 unx e series symbols
» 4xxx_|EEE “hexx series [EEE symbols
5 TG TaxGux symbols
> Tdux T4xx symbols
> Tex_|EEE T4xx series IEEE symbols
» Amplifier_Audic Amplifier for audie applications
R
Resigtar
F-O-tR :

BRI N W W-Wolll =

k

®

*

TN DTYRS

Reference R?
Footprint
Datasheet ~

FIUV-TER BUELIE-ERE( FATO1ITvHEEE@

dx 154.94 dy 62.23 dist 166.97 grid 1.27

-_C}K Fooel

B
L
4
/
N
4
A
2

mm



Tvypical symbols

Many symbols are pre-installed

If you exclude sources only for
simulation, check the box of
“exclude from board”
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Component Name of symbol Visual
Resistor R
Capacitor C
Inductor L

Op amp

Ground

GND

Current source(AC)

ISIN

IDC

Voltage source(AC)

VSIN

(
Current source(DC)

(

(

Voltage source(DC)

VDC
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Prepare Tor symbols

Downloading symbols

Ex. Library for connectors (BNC, SMA, D-sub, LEMO)

1.

3.

You can download and import libraries on the internet

download the library (named
“kilab_merl 03.1ib" ) from this website

In order to import the library, click “Preferences
> Manage Symbol Libraries >- "

Please select “kilab_merl 03.lib”" and add it to
the list

Drawing symbols

Of course, we can draw a new symbol and
edit existing symbols using B> 20505

Symbol Libraries

Libraries by Scope

Global Libraries  Project Specific Libraries

Active ‘ Nickname Library Path Library Format | Options L
2 Simulation_SPICE ${KICADE_SYMBOL_DIR}/Simulation_SPICE.kicad_sym KiCad Symbols specialized for SPICE circ
2 Switch ${KICADE_SYMBOL_DIR}/Switch.kicad_sym KiCad Switch symbols
] Timer H{KICAD6_SYMBOL_DIR}/Timer.kicad_sym KiCad Assorted timer devices
] Timer_PLL $H{KICADE_SYMBOL_DIR}/Timer_PLL kicad_sym KiCad Phase locked loop (PLL) devices
] Timer_RTC ${KICADe_SYMBOL_DIR}/Timer_RTC kicad_sym KiCad Real time clock (RTC) devices
] Transformer ${KICADE_SYMBOL_DIR}/Transformer.kicad_sym KiCad Transformer symbols
] Transistor_Array ${KICADE_SYMBOL_DIR}/Transistor_Array.kicad_sym KiCad Specialized transistor arrays
] Transistor BJT ${KICADGE_SYMBOL_DIR}/Transistor_BIT.kicad_sym KiCad BIT transistor symbols
] Transistor FET ${KICADE_SYMBOL_DIR}/Transistor_FET.kicad_sym KiCad FET transistor symbols
] Transistor IGET ${KICADS_SYMBOL_DIR}/Transistor_IGET.kicad_sym KiCad IGBT transistor symbols
[ ] Transistor_Power_Module ${KICADE_SYMBOL_DIR}/Transistor_Power_Modulekicad_sym KiCad Transistor power medules
[ ] Triac_Thyristor ${KICADGE_SYMBOL_DIR} Triac_Thyristor. kicad_sym KiCad TRIAC and thyristor symbols
[} Valve ${KICADE_SYMBOL_DIR} Valve.kicad_sym KiCad Valve symbols
[ ] _V_Eleg — ${KICADE_SYMBOL_DIR} Video.kicad_sym KiCad Video symbols
¢ a— KiLib_merl_03 N C¥lUsers¥masay¥Downloads¥KiLib_merl_03.lib Legacy

-~ -

+ m W

Path Substitutions:

HKICADE_SYMBOL_DIR} C:¥Program Files¥KiCad¥6.0¥share¥kicad¥symbols¥

S{KIPRIMOD}

FO~/BAOTOZTI NDEIEE > il 51 T 7)-FEELET

Migrate Libraries

C:¥Jsers¥masay¥¥ 1 M5 J¥u-tokyo(google drive sync)¥activity in |ab¥DECIGO_angle_demenstration¥LowPassFilter/FA{¥LowPassFilter

0K Cancel

11


http://jaco.ec.t.kanazawa-u.ac.jp/edu/vlsi/kicad/03.html

Wiring and Annotation

Annotate Schematic

Scope

Annotation : numbering components o

(O Current sheet only

() Selection only

1. Click “Tools > Annotate T o
Schematic > Annotate”

() Reset existing annotations

Annotation Messages:

2. Connect the components 2. “R?", “C?” will be numbered like

<

I?
ISIN
ac 1 sin(0 1 1k)

!

R?
10k

1 e
T 252p

|

L?
100u

“Rl”, “CZ”

Order
© Sort symbols by X position

() Sort symbols by ¥ position

MNumbering
© Use first free number after 0

() First free after sheet number X 100
() First free after sheet number X 1000

Show: @Al BErors “ 8 Warnings “ @ Actions B Infos

Clear Annotation

Annotate

I? I:I R? _L c? L? 11
n. ) ISIN 10k T 252p 100u ISIN
ac 1 sin{0 1 1k) t - ac 1 sin(0 1 1k) 1

j_ c2 L2

10k T 252p 100u

I I

GND GND

Wiring Annotation
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Save...

Close



Associating footprints with symbols

If you are going to design printed board, it is
necessary to associate footprints with symbols in
the diagram

Footprints : figures printed in the board

Package_SO > SOIC-8_3.9x4.9mm_P1.27mm (8-pin op amp )

Double-click a symbol and open the property
window

Click “footprint” box and choose a footprint

You can confirm and edit the list of footprints by
visiting “Tools > Assign Footprints”

o TRV REEIYSET
TP F BEE

FobTUE S4T30
Audio_Madule

Battery
Button_Switch_Hevboard
Button_Switch_SHD
Button_Switch_THT
Buzzer_Beeper
Calibration_Scale
Capacitor_SD
Capacitor_Tantalum_SHD
Capacitor_THT
Connector
Connector_AMASS
Connector_fmphenol
Connector_fudio
Donnector_BarrelJack
Connector_Card
Connector_Coaxial
Connector_DIN
Connector_Dsub
Connector_FFC-FPC
Connector_Harting
Connector_Harwin
Connector_HOMI
Connector_Hirose
Connector_IDC
Connector_JAE
Connectar_JST
Donnector_Malex
Connector PCBEdze
Connector_Phoenix_GHSTE
Connector_Phoenix _MC

Connector_Phaenix _MC_HizhVoltage

Connector_Phoenix _MSTE
Connector_Pin
Connector_PinHeader_1.
Connector_PinHeader_1.
Connector_PinHeader_2.
Connector_PinHeader 2.
Connector_PinSocket _1.
Connector_PinSocket 1
Donnector_PinSocket 2.
Connector_PinSocket 2.
Connector_RJ
Connector_Samtec

B

00mm
2Tmm
00mm
Sdmm
00mm

- 2Tum

00mm
Sdmm

Connector_Samtec_HLE_ZHD
Connector_Samtec_HLE_THT

Connector_SATA_SAS
Connector_Stocko

Connector_TE-Connect ivity

F4) 51 54F5U- (Audic_Module): 2

L]

B e =

list of footprints

B 6 ‘ FITYh T ] ‘

YUl 79TV REIUET

1 Cl - LRIV
2 G2 - 33u
k] ca - 2.In:
4 G4 - 56p :
5 g - o
E Ce - 0.1y :
7 C7 -

] ce - 0.1y :
k] ca - 0o
10 c1o - 0y
11 cn - 2.In:
12 ciz - BEp !
13 C1g - 0
14 Cl4 - 0y
15 G156 -

16 cle - 0.

17 C17 - .

18 cle - 0.

149 C1g - 1.

0 ceo - I,

il cal - REp :
22 cez - SEp :
23 ces - 3p
24 ced - 0
25 ces - 0y
26 ceg -

27 ce7 - 0y
8 C28 - O.lu
29 ceg -

an can - .

H car - 0.

a2 £z - .

33 cas - 0.

a4 Cad - .

ki g - o

6 cag - 0.

L Caz - 20p :
an cag - LRIV
k] cag - 0o
40 c40 - 20p
41 Ca41 - 20p :
42 cz - 20p
43 J1 - DB Female :
44 L -

45 L2 - TR
46 L3 -

47 L4 - TR
44 Lg -

In:

In:
Tu s
fu
Tu s
In:
In

In:

In:
fu
Tu s
fu
Tu s
fu
Tu s
fu:

Tu

Tu s

Tu s

SamacSys_Parts:CAPPRI
SamacSys_Parts: CAPPRI
Capacitor_SMD:C_0BO03
Capacitor_SHD:C_0201
Capacitor_SMD=C_0201,
Capacitor_SHD:C_1206,
Capacitor_SMDZC_0201,
Capacitor_SHD:C_1206,
Capacitor_SMDZC_1206_
Capacitor_SMD:C_1208_
Capacitor_SMDZC_0B03,
Capacitor_SMD:C_0201.
Capacitor_SMDZC_0201_
Capacitor_SMDzC_1206
Capacitor_SHD:C_0201,
Capacitor_SMDzC_1206
Capacitor_SHD:C_1206,
Capacitor_SMDzC_1206
Capacitor_SHD:C_0E03
Capacitor_SMDZC_0B03,
Capacitor_SHD:C_0201
Capacitor_SMDZC_0201_
Capacitor_SMD:C_0201,
Capacitor_SMDZC_0201_
Capacitor_SMDzC_1206
Capacitor_SMDZC_0201_
Capacitor_SMDzC_1206
Capacitor_SHD:G_1208,
Capacitor_SMD:C_0201.
Capacitor_SHD:C_1206,
Capacitor_SMDzC_1206
Capacitor_SHD:C_1206,
Capacitor_SMDZC_1206
Capacitor_SHD:C_1206,
Capacitor_SMDZC_1206_
Capacitor_SMD:C_1208_
My _device_for _RFOPD:.
SamacSys_Parts:CAPPRI
Capacitor_SMDZC_1206_
My_device_for RFOPD:.
Wy_device_for_RFOFD:.
My_device_for RFOPD:.
Connectaor_Dsub: DEUB-{
SamacSys_Part st LOHEE!
SamacSys_Part sz OHER!
SamacTys_Partsi LOHEE:
SamacSys_Part sz OHER!
SamacSys_Partsi LOHEE:

5475\ ~{EE: C:/Users/masay/OneDrive/ F¥14% k/PCBpartsLibrary/SamacSys_Parts.pretty

ERLT. EEEDRT & &iT

FlF-EniTubFUsb

1 dudio_Module:Reverb_BTOR-1H
2 dudio_Module:Reverb_BTDR-1Y

ok |

Frotl

w



Prepare for Tootprints

If you cannot find proper footprints, you can download
footprints from various website

1.

In order to import footprints, it is necessary to
install Library loader from this website

+

Creating your account of Library loader
Reference

Add “SamacSys_Parts” to footprint libraries

Download and open ECAD Model, “***.epw”

2 Library Loader V249 -

. Open ECAD Model | Bearch for Portjcnwon | Profile | Feedback | Help
Dom;ga-c-ls—F;IJer C¥lUzers¥mazay¥Donnloads Bromse
‘our EGAD Tool  KiCad EDA w Settings
History since 05:18 an 12/05/2022 Check for Update

LOHEESM 1ROMO3L

FybFUY 54T~

AI-FRISATFU-
J0-10L 34T3Y-  FosrsrEEDIAT5Y-

79747 | RIB(C977-L)

2 TerminalBlock_MetzConnect ${KICA
2 TerminalBlock_Philmore F{KICA
2 TerminalBlock_Phoenix F{KICA
[ ] TerminalBlock_RND ${KICA
2 TerminalBlock_TE-Connectivity ${KICA
2 TerminalBlock_WAGO ${KICA
[ /] TerminalBlock_Wuerth ${KICA
[ /] TestPoint ${KICA
2 Transformer_SMD ${KICA
2 Transformer_THT ${KICA
2 Transistor_Power_Module ${KICA
2 Valve ${KICA
[ ] Varistor ${KICA
2 My_device_for_RFQPD CflUse
2 SamacSys_Parts C/fUse

+|mv T[] (@

EESN TSI

4{KICADE_3DMODEL_DIR}  C:¥Program Files¥KiCad¥6.0

RS

Saal= .§ F—D— I BECRS

A ZHEm A DS REEEA ST

Murata Big1 > 4504 (H=E
LQH66SNT1ROMO3L

RSonE: 725-5333 X —H—AUZ&: LQH66SNT1ROMO3L

FKEEEA T d

F—53—h

Chip Inductor (Chip Coil) Power Inductor
(Wire Wound Type for Choke) LQH66S
Series (2525 Size) Data Sheet

—_——— —_— -

-

-~ -
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https://www.rs-online.com/designspark/samacsys-part-finder-jp
https://marunaka-blog.com/kicad-parts-library-add/1453/

Simulation

15



oetting parameters

T BEEM AT
A EDBA0[2C PH|ICRAAAQA|E 1|0 2> A|RBE (B sED|H

Spice £F)l IF 5~ x|

You set value of resister, capacitor, inductor,

Kovd N V-2

etc for simulation Ak i
ACHEEE: 1 VIA ACHERE: rad | | |
BEREER
KA EE  EgEm EHSF M AM SU5L | < |

POV B R OBE

DCATEYM 0 WIA

Double-click a symbol |7 I
ISIN - .

BE:

a C 1 S i n (G AERE 1/sec _ IE
Change “Value” box such as 100k, 0.1u ,
—BEE AEL08YST 2T i
F1=JLE | | ‘ | = OEE QA E
o S Ne b[l-‘zs:bﬁa)?-))fﬁlb&ﬁ%{t .
If the symbol is spice model such as current D e w0 gowsseo |
. i“ . ” Dotashet - 0 == w0 @ oK ol ||
source, op-amp, please click “spice model” and oesen s ¥ == !
“h . . ” S;ce:MDde\ ac 1sin(011k) - E ;; E| 1127 :: ’ ? I
open “spice model editor e ° s L:
won . C
R \:ZI/::T;;;E%?. 51755y IRIEES... |_
BELRI (R TN Dz YTIEER.. I I
- o SURIERE. @m@
Edit DC/AC voltage m | |G
F4F5U= U2 Simulation_SPICEISIN g i S-p-ic:f;ﬂr: = oK Fotll

~ -~ -
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Very simple example of simulation

_ - 11 R2 _L C2 L2
A very simple example, RLC circuit, is shown ISIN 10k T 252p 100u
in the figures ac 1 sin(0 1 1k)

Resonant frequency : 1 MHz

G N D e Simulation  View
Sim Parameters
Simulation settings X
AC DC Transfer Operating Point  Transient  Custom

1. Click “Inspect > Simulator” and open the simulation window

MNumber of points:

2. Clink “Sim Parameter” )

Stop frequency:

Hertz
Sim Parameters

(] Adjust passive symbol values (e.g. M — Meg; 100 nF — 100n)
@ Add full path for.include library directives

3. You can set parameter for simulation (AC, DC transfer, etc..)




Result of simulation

1. Click “Run/Stop Simulation” to simulate the model

>

ET/FL

2. Ifyou click “Probe” and the click the upper wire,
you will get the result shown in the right figure

7

Jo-7

e Redlineis “Gain”

« Blue lineis “Phase

”

1
ISIN
ac 1 sin(0 1 1k)

GND
>

Joyh1-AC

pat ibi
cuit:
ng ana
ning:

ity
iCa

[
H
!

Com
Cir
Doi
Warr i

w o2

=fT/fFL E5Em  Jo-7 BE /G-

10Hz 100Hz 1

modes selected: |t
0 i

d schemat

enat ic
veis at TEMP = 27.000000 and TNOW =
12 no DE walue, transient time 0 wva

27.000000
0 value used

100kHz

ThHz  10MHz 10

I V(Net-(C1-Pad1)) (mag)
Il /(Net-(C1-Pad1)) (phase)



Product page of OP27(Analog Devices)

Download simulation model o e

EEIBR MYANALOG Bl FIUTr—3 | BEr2iE Fo
L3 HR > 727 > AxFLS (OPF) >

SHEEAANPT (Vos <imV & TCVes <2uV/C) > OP2T

0oP27 Ana T BT Xz

FHESY | FFo > | w—IL | EF8H | StV Y—X | R—k & T ZAhvys3

e |f you use IC circuit such as op-amp, you have s i PRy
to prepare a simulation model (mini-circuit) >rTor 5y rems )

CliCk ' ST —FS— I FER Rev.H

F— & — TFIAEOER

e Usually, you can download spice model file ([ smoEnedete
Spice TTIL I7459~ X
Ktyyd BT y-2 o
EXI O P 2 7 S4T30, C¥Users¥masay¥Downloads¥op27.cir Vae - ;71’ ILEEEH-?: 1 \’ RAL “"

= [op e vl 4 i
1. To import the file, open the property 57 vyem . e

Vos TRIM [1] [5] Vos TRIM
: x SV EVOF YUY INBRENE SPICE OF IBL —HLELA 4-: n%n -
window of the sSym bol such as ) SUTINEREL. B EGEE Y OERER 8 /—F y—7Ix EEALTTA B >
g

current |imit

2. “Spice Model > Model Tab > Select file” |

3. Select the file you downloaded

Jyzmab-vaveyumlEEsht
BE/-Foy-Tyx 32746

19
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https://www.analog.com/jp/products/op27.html

— DOI’J[ Netlist ! :
X | L :
! 11 |l| R1 c1 éLl I~
I51f Export Netlist X /

ac
KiCad  OrcadPCB2 CadStar Spice /
2

If you want to design a circuit board, Netlist is required .

P
=
S
4 %

e ———

\
/
[

Add Generator...| |Remove Generator

T R

&l

Netlist displays the network of components

LOOTHNIENL L TN T "I'")l Wi e "")')'
(comment (number "87) (value %%

You can export it by “File > Export > Netlist > Export Netlist” Coprent (e ) (it 9
components
{com (ref C1 )
value "252p")

||bsource (lib "Device™ (part "C") (description "Unpclarized capacitor™))
(property (mame “Sheetname”) (value ~
Epﬁopfrt¥h(?ame Sh?egf&let) (valﬁe))LowPassFllter kicad_sch™))
. s skk ok ” . . sheetpath (names stamps
Filename is .net” and you can open it by usual text editer (istams ST5HG-£210-45 B89 Tact 95260
cop (re
value "ISINT)
(fields .
(field (rame "Spice_Model™) "ac 1 sjn(0 ] 1k)™)
{(field (name "Spice_Net|list Enabled YT
(field (name "Spice Primitive”) ”
(libsource (lib "Simulation_SPICE” ) (pgrt "ISIN™) (description "Current source, sinusoidal™))
(property (rame "Spice_Met!ist_Epabled’) (ga ue
(property (name "Spice Primitive”) (value “17)) .
(property (rame "Spice_Model ™) (valug “ac S|n(0 11170
(property (rame “Sheetname”) (value B
property (name Sheetflle ) (value “LowPassFi lter.kicad sch™))
(shestpath_(names /") (ts )
(tstamps "7934eefc-7h8e- 4e98 bd4a Tb00de2652227))
(comp (ref
(value "100y") . . .
(libsource (1ib ~ DeV|ce ) (pa;t "L )ngé?scription Inductor™))

N L [P ) R

Contents of Netlist



Designing circuit boards




import Netlist

Import Metlist

Metlist file: | (]

Import Netlist

Link Method Opticns

() Link footprints using component tstamps (unique ids) Replace footprints with those specified in netlist

. . . . [T Delete footprints with no components in netlist
© Link footprints using reference designators — P P

- - = — - .
° Y n b rl n g f rl n fr m mﬁlﬂllj'»f’? |_| Delete tracks shorting multiple nets
Ou Ca 00 t p tS 0 = UEriMEEEEEELST
H H H Changes To Be Applied

by l m p O rtl n g N etl I St Warning: Mo net found for symbol L2 pin 1.

Warning: Mo net found for symbol U2 pin 5.

Warning: Mo net found for symbol L2 pin 8.

Warning: Mo net found for symbol U4 pin 8.

Warning: Mo net found for symbol U4 pin 5.

Warning: Mo net found for symbol U3 pin 1.

. Warning: Mo net found for svmbol J1 pin 0.
PCBIF (4~ .
° TmeorosrrrsEssr 1S USed

Total warninzz: 0, errors: 0.

Show: (@ All Errors (D Warnings 26 Actions Infos Save...

1. Click “File > Import > Netlist” and
select the netlist file

Update PCB Close

2. Click “Update PCB”

3. Footprints are putin order

RFQPD footprints
are imported




Setting properties and design rules

Setting properties

We define properties of board such as
the number of layers

Click “File > Board Setup” and open
window

Choose the number of layers in “Board
Stackup > Physical Stack up”

Design rules

Design rules must be determined to
avoid errors when manufacturing

Recommended design rules are

summarizedin U >y FEMyELEEAESE

[=- Board Stackup

Board Editor Layers
Physical Stackup
Board Finish
Solder Mask/Paste
Text & Graphics
Defaults

Text Variables

=- Design Rules

i Constraints
Pre-defined Sizes
Met Classes

i Custom Rules

" Violation Severity

Board Setup X
== .
Bl B_oard Stackup Copper |q(.rer5: 4w 7 [ Impedance controlled Add Dielectric Layer.., Remove Dielectric Layer..
Board Editor Layers Sao o=~
- Physical Stackup Layer Id Type Material Thickness B Color Epsilon R Loss Tan
- Board Finish
- Solder Mask/Paste m [Silkscreen  Top Silk Screen Not specified __. Not specifiec ~
- Text & Graphics FEPaste Top Solder Paste
- Defaults -
L Text Variables mmm FMask Top Sclder Mask Not specified 0.01 mm . Not specifiec ~ | 3.3 i}
B De5|gn Rules ECu Copper 0.035 mm
- Constraints mm Dielectric 1 G FR4 1.51 O 45 002
i v .51 mm . .
i Pre-defined Sizes \Elecine ore —
i Net Classes In1.Cu Copper 0.035 mm
C_UStD!.n Rules W Dielectric 2 PrePreg ~  FR4 1.51 mm O 4.5 0.02
L. Violation Severity
In2.Cu Copper 0.035 mm
“5 0.02
Allowed features Copper s .

/O Allow blind/buried vias

/ [ Allow micro vias (pVias)

Arc/circle approximated by segments

2 X W 7§

Max allowed deviation: 0,005 mim
Mote: zone filling can be slow when < 0005 mm.
Zone fill strategy
_ Holes
) Mimi i
E ) Mimic legacy behavior }f’
© Smoothed polygons (best performance) ,;(
L ] Allow fillets outside zone outline !
Length tuning uVias
B Include stackup height in track length calculations y/Z
L
o
P

Import Settings from Another Board...

Minimum clearance: Q18
Minimum track width: 0.2
Minimum annular width: ~ 0.05
Minimum via diameter: 0.4
Copper to hole clearance:  0.25

Copper to edge clearance: 1

Minimum through hole: Q.3

0.25

Hole to hole clearance:

Minimum uVia diameter 0.2

Minimum uVia hole: a1

[ o ]

[t

mm

mm

mm

mm

mm

i

i

i

iy

Cancel

Export to Clipboard

<
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https://www.p-ban.com/information/data/manufacture_standard.pdf

Roles of many layers

There are many layers in a circuit board

When you wire or make solid pattern, it
is important to understand the
definition of the layers

Ex) 4-layer board

Layername | Layer Role HAE TOREHR
F.Cu 1 Pattern /Xy ROFRRR(ER) D8
F.Mask 1 Resist sk oEN D)=
F.Paste 1 Metalmask | IZAZHITDI-HDEEDE
F.Silkscreen 1 Silk HmESTEDNTE
B.Cu 4 Pattern /3y ROEERR (B D JE
B.Mask 4 Resist Lo NN =
B.Paste 4 Metalmask | (AT ITD/I-HDEEDE
B.Silkscreen 4 Silk HEmESTEDHNFTE
In1.Cu 2 Pattern /Xy KX BCAR (B) D
In2.Cu 3 Pattern /Xy KRR (B D
Edge.Cuts EIRONFEDE

UAP= ATUIOh Rub
W & rcu
@ in.cu
& nzcu
|_Nolia

W ./ Fadhesive
W ./ BAdhesive
/) FPaste

M / BPaste
@F.Silk_."creen
@ BSilkscreen
7 FMask
/7 BMask
#7 User.Drawings

M/ UserComments
/7 UserEcol
/" UserEcol2

b & Edgetuts

M ./ Margin

W /) FCourtyard
/" B.Courtyard
/" FFab

M 7 BFab
7 Userl

M ./ User2
# User3
# Userd
/7 Users

M /) Users
2 User7
7 User8
# Userd

24



Arranging and Wiring

Arrange the footprints(components) as you like

There are many articles about reducing electrical
noise on / 4 AJf%.com

White lines in the above figure show the two pins
should be connected when wiring

o000y
e



https://www.noise-counterplan.com/

Design rules check (DRC)

Design Rule Check : check whether the board
violate the design rule you ser up

Track: use netclass width | = I Via: use netclass sizes | Grid: 0.2000 mm (0.0079 in) ~ | ZoomAuto

DRC Centrol

B Refill all zones before performing DRC [ Test for parity between PCB and schematic
[_JReport all errors for each track

It is recommended to execute DRC frequently | oD Snconmected e | Schematec Pty (oot

Footprint C31
~ Warmning: Courtyards overlap
Footprint L7
Footprint C25
. “ . “ ~ Warning: Silkscreen clipped by solder mask
Click “Inspect > Design Rules Checker > Run DRC :
. Line on ESilkscreen
~ Warmning: Silkscreen clipped by solder mask
Rect on Edge.Cuts
Line on ESilkscreen

~ Warning: Silkscreen clipped by solder mask

If there are errors, correct them until the number of
them get tO be 0 INE oN RallKSCreen

Show: [C]All Berors B Warnings 11 [ Exclusions Save..

Delete Marker,  Delete All Markers Run DRC Close

If there is no errors, you can move on to exportation
Of Data Pads Vias Track Segments Nets Unrouted

26



-xport Gerber data and drill data

In order to place an order, “Gerber data” and "drill
data” are required

Clicking “File > Plot” and open a window

Reference to check/uncheck the box and export
Gerber data is here

If you click “Plot”, Gerber data will be exported
After clicking “Generate Drill Files” and opening
Generate Drill Files window, please click “Generate
Drill File”, “Generate Map File”, “Generate Report
File”

You will get drill data

2ot
Plot format:  Gerber

Include Layers

() UserEco1
(] UserEco2
B Fdge.Cuts
() Margin
(] FCourtyard
(] B.Courtyard
(O FFab
Oefb
Output Messages
Generate Drill Files
Show: (Al
Output folder: u
Drill File Format Drill Origin BunDRC
(el O Absalute
[ Mirror Y axis

(] Minimal header
8 PTH and NPTH in single file

© Crill/place file origin

v Output directory: ./

General Options

[T Plot border and title black

18 Plot footprint values

8 Plot reference designators

[ Force plotting of invisible values / refs
[ Plot Edge.Cuts on all layers

([ Sketch pads on fabrication layers

8 Do not tent vias

Gerber Options
8 Use Protel filename extensions
[C) Generate Gerber job file

(] Subtract soldermask from silkscreen

Berors @ Bwanings @ @ Actions

Plated pads: 43
Mon-plated pads: 0
Through vias: 42

Oval Holes Drill Mode Bl Micro vias: 0
© Use route command (recommended) O Millimeters Buried vias: ¢
O Use slternate drill mode O Inches
() Gerber X2 Zeros Format
() Decimal format (recommended)
MaplblEbounat 1O Suppress leading zeros
O HPGL () Suppress trailing zeros
O PostScript () Keep zeros
© Gerber
() DXF Precision:  3:3
CQSVG
O PDF
Messages
Generate Report File... Generate Drill File Close Generate Map File

Drill marks: None
Scaling:
Plot mode: Filled

18 Use drill/place file origin

18 Check zone fills before plotting

Global solder mask minimum width and/or margin are not set to 0.

| Most board manufacturers expect 0 and use their own constraints for solder mask minimum width.

Board setup

Coordinate format: 4.6, unit mm il
[C) Use extended X2 format (recommended)
[J Include netlist attributes

[[] Disable aperture macros (not recommended)

8 Infos

Save...

Plot Close Generate Drill Files...
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https://www.p-ban.com/gerber/kicad.html

(serber data and drill data list

Ex) 4-layer board

Gerber data
Filename Layer Role BAE CTOfER
Circuit board consists of many layers. = _F Cugtl 1 Pattern <y Pl CEE) -9 5 B
Therefore, many kinds of files are **%_F Mask.gts 1 Resist HEFAAICEE T 2158,
needed to be manufactured **%_F Paste.gtp 1 Metalmask AT DI=dDBEEICET 215K
**%_F Gjlkscreen.gto 1 Silk MRESKEDHNFICET 2 IER
**%_B Cu.gbl 4 Pattern /Xy KRR (BR) (B89 2 1B
**%_B Mask.gbs 4 Resist feBRIAICE T 5158,
Drill data **x_B Paste.ghp 4 Metalmask AT DI-dDBEEICET 5158
Filename Data name BAE TOEHR *#*_B_Sjlkscreen.gho 4 Silk HRBESHEDNFICET 2ER
k% | Drill data INDIGAT D RERIZE T 5 153 *#%_In1_Cu.g2 2 Pattern 7%y NROECHR (GB24A) ICBE 4 5 153
***_dr|.rpt Drill list NOEFEE KT S ICET B IER **%_|n2_Cu.g3 3 Pattern Xy ROBRAR(CER) IR 21853
***_dr|_map.gbr | Drill map file ***%_Edge Cuts.gml EAR DA ICEET 2 1B

You can see {LERT—X

seBAZ= (ptk) for details
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https://www.p-ban.com/information/data/beginner_garber_data_manual.pdf

Place an order
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Place an order

In Ando Lab, P#r.com is often used

Before placing an order, 3 steps are needed

1. Prepare for data
2. Check the design rule
3. Estimate

4. Place an order

Pﬁ E—NYRyhdLA
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What files do you need to submit ?

There is a list of data when you order on here

Gerber data

Drill data

Manufacturing instraction (Bl¥sfgRE)

Parts list (Bga Y X F) excel file

Mount drawing (£%X])

AR PA-F 5 2t EX e A R
F17 v S
A B C D E F G H 1 J K L M 0 P
rtslist(Rev,2.41) N
1 pa [ - 2B
i e | B BaKB | zupme | PRV | o
, | parts_list_RFQPD_free.xls| mzmmmm EBES Lo Anvees | BR | Tt
UIrLYZ
13 e
3 HHIeTAETANBA EABRET I8 | & |X&E®| SMD | DIP [CORL
B -] pninl el Bl BGAY L B (FH)
Mo | A=h— ERERHREI YR
s0 70|255| 75 |75 | 0| o 10
# KOA FuTER RK73B2ATTD1002F R1,R5,R9,R10 4 2 8 EEW SMD
5
6 - .
1 . R1,R6,R7,R12,R13,R1
b o KDA Fu R RK73H1JTTD49R9F 4,R23,R24 8 2 E<"Y SMD
é KOA FuTEH RN73H1JTTD3300B25| R3,R9,R17,R18 4 2 E SMD
3
3 RN73H2ATTD1001B2 |R4,R5,R10,R11,R19,R|
N KOA FuTER 5 20,021,802 8 2 E SMD
é KOA Fy RN RK73H1ITTD2701F R2,RB,R15,R16 4 2 E< SMD
10
2 |mees|  mgmasy- | CRMOIISCARIINCA0] - cgc43,603,004 4 2 £ SMD
1
S |umers|  momay- | CRMOIIBCIRSEOGAC] oq c4p ca1,020 4 2 E SMD
12
! |umer|  momasy- | SRMOIRIIMIOMALL 65 615 06,020 af 2 SMD
13
E e Fvriussy- | CRMIBBSCIH22DIA0 | gy (16 020 i 2 Fy SMD
1
C6,C8,C9,C10,C14,C1
E IR EAERR FyFALF M- GRM31M3ULH1041A0 6,C17,C18,C25,C27,C 19 2 ¥ SMD
15 28,C30,C31,C32,C33,
130 Voltronics|  AJEILF - 12200 €37,C40,C41,C42 4 2 E SMD
16
11| Anslog .
E O | Devices ARTLT QOP27GRZ uz2,u4,u6,U8 4 8 =Y SMD
12 | Anslog .
R O | Devices ARFLT AD811IRZ u1,U3,us,u7 4 8 E=Y SMD
1:?; RS PRO |SMATyZ¥-b150%| RSE#: 526-5785 P1,P2,P3,P4 4 s E=Y SMD
19
14 [RERNZT| gk g4 G689 G6849 108 *EW L

Parts list examp

e

Mount drawing example
(from here)

LED1

”ooooLcB—QJN O 0 0 02

49/0 © 0 00 O 0 0 O[04

LED2

L

[RE.

HEH

20

8“60000
1

1ojloo oo o0 o 00|

,J0 000

0,0) —X
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https://www.p-ban.com/information/data/parts_list.xls
https://www.p-ban.com/product/orderdata.html
https://www.p-ban.com/implementation/mount_drawing_sample.html

P-ban WEB Checker and Estimate

* You can confirm whether your board violate the manufacture standard or not

« |f there is no problem, you can smoothly move on the next step, Estimate

P-ban WEB Checker Result Website for the estimate

Pr.coim | 1-Click R5%
NN = s |0

)y R ZLFLTNEBE A% MRS N=FZAWMT AINTRY k- =2

S -8
nnnnnnnnnnnnnnnnnnnnnnnnnnnn = "
IS~ \—F—45 (RS-274X) At
FuF—% (17+€0%) L
— RUEhSERGUPT7AIV .
® um
HEmH ..... W
@ EE

Place an order
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https://www.p-ban.com/kiban/com/csComEntDrc.do
https://www.p-ban.com/kiban/com/csComEst.do

Summary Ando Lab Wiki (#2581 X +)
[ER% *
. s Resonant RFPD circuit board
 Introduced KiCad and the usage e Filter circuit for Lorentz invariance test
« Drawing diagrams
« Simulation
« Designing boards

3rd-order LPF for Lorentz invariance test
Whitening Filter for Mag 649

Whitening Filter for Mag 13
0.1-3HzDAAEREREE(EFEL)
1-30HzD iR ERRE(TFFLE)
O—JIA T v ILFEE(EFZEL)

« Differential Amplifier

Photo sensor board (5G-2BC)

Coil driver board (4CH)

« Should be installed
« KiCad
« Library Loader

 Offset adjustment and 4x4 matrix operation circuit board
« On the internet, there are many works . Sigeprg'tﬁgtﬁg ﬁf,:;gg;ﬂiirmt
 Libraries of symbols » QPD Yaw/Pitch/Sum board
e |Libraries of fOOth’iI’ltS « Switchable filter curcuit (5T560)
. . o Offset-Sum circuit
« Simulation models e Offset-Sum-Monitor

[€cad =2
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https://granite.phys.s.u-tokyo.ac.jp/wiki/Lab/?AndoLabInstruments#l128ceb5

Thank you tor listening



